**Contents**

Disclaimer 3
Acknowledgments 3
Introduction 3
The Main Screen 4
The Inspector Palette 6
  Lithologies/Formations Group Box 7
  Appearance of the Section 7
  The Well Data Tab 8
Entering and Saving a Section 8
  Reading in an Already Measured Section 8
    From Strat Mobile 8
    From the Desktop 9
    From a Text File Created by Another Program 9
    From Well Data 10
Entering a Section from Scratch 11
Editing an Already Entered Section 12
Saving Your Data and Graphical Section 13
Exporting Information 14
  Lithology Definitions 14
  Formation Definitions 14
  Export for SedLog 14
Menu Summary 15
  File Menu 15
  Edit Menu 16
  Section Menu 16
  Plot Menu 17
  Windows Menu 17
  Help Menu 17
Disclaimer

Strat Desktop is provided “as is” with no without any warranty, explicit or implicit. The author will not be liable for direct, indirect, incidental, or consequential damages resulting from any defect in this software or this user's manual, even if he has been previously been made aware of the defect. Furthermore, I make no systematic effort to inform all users of either bug fixes or upgrades. Use this app at your own risk. This program may not be sold or offered as an inducement to buy any other product.

Acknowledgments

I appreciate the beta-testing prowess of Robert Hall, Teresa Jordan, Tasnuva Ming Khan, and Néstor Cardozo.

Any errors are mine but, remember, it is completely up to you to verify that the program is working and yielding reliable results for your purposes. All computer programs have bugs in them!

Introduction

Strat Desktop is a desktop companion program to my iOS app, Strat Mobile, though it can also be used as a completely independent program. In short, the program facilitates the viewing, editing, and entering new data on stratigraphic columns on the desktop. Those columns can be saved as .SVG files which are readable by most modern vector graphics programs like Adobe Illustrator, etc. The data files that Strat Desktop saves can be read back into Strat Mobile.

Strat Desktop can run on MacOS X, Windows, and Linux computers. It is a document based application, meaning that you can have several different sections open in different Windows. To create a new window for a new section, select File>New. The window will be blank until you read in some data or start creating a section manually by adding intervals.

In the lexicon of the program, measured stratigraphic units are referred to as “intervals”. Intervals can be assigned a lithology, a formation name, or both; you can only assign colors either by lithology or formation name but not both. If you have entered well data, in addition to the usual parameters, you can assign a sonic (interval) velocity and plot your section in two way travel time rather than depth. Point observations are called “samples” but they can represent any point observation you want —
photographs, identification of a particular fossil, measurement of a feature, or, yes, even a sample — regardless of whether you physically collected a sample there. Sections are always defined from the base upwards, though if entering data manually, you can create one top downwards by using **Section>Add Interval to Base**.

---

### The Main Screen

The primary work space of Strat Desktop is divided into two halves: On the left side of the screen is the canvas where a graphical representation is plotted. The graphic has a scale showing thicknesses in the units of the stratigraphic section. Those units can be changed in the **Inspector Palette**. To the left of the scale, small diamond symbols show point observations or samples. To the right of the scale is the stratigraphic section and **Legend**. Strat Desktop uses colors and widths to represent lithologic units rather than patterns. Those colors and widths can be changed, and units renamed or added, in the...
Inspector Palette. You can define as many units as you want. The appearance of the right edge of the section — whether you use ragged or straight edges, as well as other graphical characteristics such as outline, etc. — are also defined in the Inspector Palette.

The right side of the screen displays the data in three different tabs: The Data Tab provides an overview of both the measured intervals and the samples in two list boxes. To see all the recorded details of an individual interval or sample select it, either by clicking on its row in the list box or by clicking on the unit or sample itself in the stratigraphic column on the left. Then, click on either the Interval Details or Sample Details tab. These views offer similar, but not identical information. All of these field are recorded automatically when you measure a section with Strat Mobile. If you are entering a section by hand, the only required information in the Interval Details tab is the thickness and the lithology; with those two alone, you can make a stratigraphic section. Manual entry of data in the Sample Details tab requires either the distance of the sample above the
base of the section, or the interval number and the distance above the base of the interval. You will also want to define the type of sample. This is entered in a combo box where you can either select an existing sample type from the drop down list or type in a new sample type. Any new sample types, once the update same button is clicked, will be added to the sample types list automatically and so will be available for subsequent samples. In both tabs, the notes field will take whatever freeform entry you want of any length.

Every field can be modified or changed for an existing section. In the Interval Details tab, you can specify that the unit appear tapered and widening upward or downward by clicking the “wider at” checkbox and then selecting the appropriate radio button. This is specified on an interval by interval basis. In the main screen view, the lowest sandstone unit was marked as wider at the bottom whereas the sandstone unit in the middle of the section was defined as wider at the top.

Some changes in the Sample Detail tab are linked: For example, if you change the distance of the sample above the base of the section, the program will calculate automatically what interval the sample is in and how far above the base of that interval it is. If you change the interval number, the distance above the base of the section will be change to the base of the new interval and the distance above the base of the interval text box will be selected for you to enter where in the unit it lies. You cannot enter a value in that text box which is greater than the thickness of the unit in which it lies. If you change any of these values, a “Restore” button will appear automatically in the lower left side of the tab, allowing you to revert to the previously saved values.

Eventually, but not at present, the “Elevation” label will be a live button which will allow you to retrieve the elevation corresponding to the latitude and longitude value from an Internet elevation server.

Your changes are not recorded until you click the Update… button in the lower right.

---

**The Inspector Palette**

You can specify or change units with the dropdown menu at the top of the Inspector Palette. If you have already entered data for a section in one, say feet (ft), and want to switch to meters (m), all of your already entered data will be converted to meters. A dialog box will warn you that this is about to happen and give you a chance to cancel. Of course, you can switch to meters and then back to feet again at will.
Lithologies/Formations Group Box

You define the color and the width of each lithology in the Lithologies group box. Just select the rock type that you want to edit from the drop down menu and use the slider for the width and color box to select the colors. The width is specified as a percentage between 10 and 100% with the selected value shown to the right of the slider. Your changes are reflected in realtime in the stratigraphic column in the main window. You can rename an existing lithology by clicking the Rename button and add a new lithology with the Add New button. In both cases a sheet window will appear where you can enter a new name or cancel the operation. Any new lithologies that you add are initially given a random color and a width of 50%. Your changes will immediately become available in the lithologies drop down menu in the Interval Details tab.

Appearance of the Section

The remainder of the Inspector Palette is devoted to the appearance of your stratigraphic section both in the main window and in .SVG files that you save. The right edge of your section can either be ragged or straight by toggling the “section has ragged edge” checkbox. If ragged, the program will compute some “pseudo-beds” of slightly different thicknesses and “erodabilities” using a random number generator. You can control the roughness of the edge with the top slider and the relative thickness of the seed beds with the bottom slider. The thickness of the beds is also scaled by the average width of the unit defined in the lithologies section. If you want to see the pseudo-beds plotted, check the “plot schematic beds” checkbox.
The final two choices allow you to plot your section with or without a black line around each interval and whether to plot the section as a black and white line drawing with no color at all. You might want to plot a black line around each color filled interval if, for example, you have two units of the same lithology adjacent to each other in the section or just if you think it looks better.

The Well Data Tab

Here, you tell Strat Desktop whether to color your section by lithology or by formation name. Sonic velocities is automatically checked if you have entered well data with velocity information but you can also turn it on manually. Doing so will make the sonic velocities text box in the Interval Details pane visible. You can then type in the velocities by hand for each of your units. If you only have velocities for some units, you can have Strat Desktop automatically assign velocities to the rest of the units in your section by selecting Section>Well Data>Extrapolate Velocities (which is not necessarily ideal!).

Finally, if sonic velocities have been enabled, you wills the plot in two way time check-box, which is what allows you to toggle between plotting in depth and plotting in time.

Entering and Saving a Section

When the program starts or you open a new window with the File>New command, the window is blank. At this point, you can either read in a pre-existing section already saved to disk or start entering data manually.

Reading in an Already Measured Section

From Strat Mobile

Strat Desktop was designed for viewing, editing, and producing high quality graphics from sections measured with Strat Mobile for iOS. Simply move your Strat Mobile data file to you desktop computer and then choose File>Open and locate the Strat Mobile file. You can move the Strat Mobile file to your desktop in various ways, depending on the computer you have. For Mac users, perhaps the most convenient way is using Air-Drop or iCloudDrive which can be accessed from the Staring Panel — the icon is a box with an upward pointing arrow — in Strat Mobile. You can also paste the column into an email program and mail yourself the data or use the Notepad app, which automatically shares its data with the desktop version of note pad.
From the Desktop

Simply choose File>Open and locate any Strat Desktop or Strat Mobile file that you have previously saved. In Strat Desktop, you can also enter data that is on the system clipboard. Make sure you copy the complete file from the program that displays it (e.g., an email program) and then choose Edit>Paste Section.

If you have already entered data in the program, you will be given the opportunity to append the data to the existing section or replacing it.

As soon as you read in the section, it will be displayed with the colors and widths that you had designed for it originally.

From a Text File Created by Another Program

Strat Desktop can read any column-oriented text file, separated by tabs or commas, that was created in another stratigraphy program or in a spreadsheet program. To start, choose the text file by selecting File>Parse Column. After you identify the file have has the column to read in, the below dialog box will appear where you will assign the columns in the file to Strat Desktop data types. This window can be resized by dragging on an edge.
Use the radio buttons to tell Strat Desktop whether the data appear in the columns in top-to-bottom (i.e., the first row of data is that the top of the section and the last row at the bottom) or bottom-to-top. You can either enter thicknesses or tops of intervals, but not both. Finally, you can concatenate several columns into the notes field as shown by separating the column numbers with commas as shown in the above example. Don’t forget to assign the right units on import!

From Well Data

Strat Desktop makes it easy to plot data from vertical wells by entering the tops of formations encountered in the wells. In the spreadsheet in which you have your well data, select and copy the columns that you want to import into a blank Strat Desktop file. You can include as many columns as you like but you should not include any header columns, just data. Then, in Strat Desktop, select Section>Well Data>Add Well Data. make sure that the listbox has the focus and choose Edit>Paste. The columns from the spreadsheet will be parsed into the columns in the listbox. Then use the popup menus at the bottom of the window to tell Strat Desktop which column is which, as well as assign names, locations, and units at the top of the window. By default, Strat Desktop will assign random colors to the formations and every unit will be given a width of 50. Note that one of the columns that Strat Desktop recognizes is the one for the sonic velocity. If velocity is specified (in the same units as the tops!!), you will be able to plot the column either in depth or in two-way travel time (for comparison to seismic reflection data):
Entering a Section from Scratch

Strat Desktop can also be used to build a section from scratch, assuming that you know the true thicknesses of your beds already. With a blank window open, select Section > Add Interval to Top. The right side of the main window will automatically open the Interval Details tab where you can enter the data that you want for the interval. You may find it convenient to have the Inspector Palette open as well so that you can conveniently define new lithology types as you encounter them. When you are finished with the data for that interval, click the “Add Interval” button in the lower right to record your unit. To enter the next unit just select Section > Add Interval to Top again. You will probably find it more convenient to use the keyboard shortcut: Cmd-A (Mac) or Ctrl-A (Windows).

If you do not have the true thickness of the Interval you are addition, you can have Strat Desktop calculate the thickness from your original field data. The program can calculate thicknesses from tape measure data (see conventions, above right), GPS coordinates of the base and top, Jacob staff, or eye height data. Click the “Calculate Thickness” button that appears in the Interval Details tab just to the right of the Thickness text field. A sheet window will appear as shown below; select the tab appropriate to the method that you used to collect the data. All methods of calculating thickness except for Jacob staff
require that you enter the bedding strike and dip. As you type numbers into the boxes, the thickness will appear in real time at the bottom of the window once you have entered sufficient data. Uncertainties are calculated for GPS data by propagating typical horizontal and vertical errors for GPS receivers. This is done just for GPS data to reinforce the scale of uncertainty of those measurements!

Samples can be added by selecting Section > Add Sample. They can be added as soon as you have recorded the corresponding rock interval or added later.

**Editing an Already Entered Section**

Using the Section Menu, you can add or insert intervals or samples anywhere within your column. If you choose to Insert a unit, please note that it will be inserted stratigraphically beneath the selected bed. Editing of individual intervals or samples always requires that you press the “Update…” button to record your changes. The rest of the section will automatically be adjusted to reflect your changes.
The Section Menu is also where you can delete individual intervals or sample. If you delete an interval, *any samples associated with the interval will also be deleted* and the samples associated with intervals higher in the section will be moved down by an amount equivalent to the thickness of the deleted interval.

Deletions cannot be undone so you are asked if you are sure before it is too late!

**Saving Your Data and Graphical Section**

If you have made any changes, or you entered a section from scratch, you will want to be sure to save the section using **File>Save**. This writes a plain text file with tab-sepa-
rated columns that is compatible with Strat Mobile for iOS and can also be read back in to Strat Desktop at any time.

The plot of the section can be saved as a high quality vector graphic by choosing
File>Save SVG File. SVG stand for scaleable vector graphics that is an open standard vector format readable by most modern graphics programs like Adobe Illustrator, Affinity Designer, Corel Draw, etc. It is also the standard vector format designed for the World Wide Web and therefore can also be opened and displayed by any modern web browser. If you have a vector graphics program that cannot open .svg files, you can open the file in your web browser and from there save the file as .pdf which should then be openable in many more programs. An example vector graphic is shown, below.

Exporting Information

Lithology Definitions

Lithology definitions can be exported as a simple text file by choosing File>Export Lithology Types. This file can be read into another stratigraphic section in Strat Desktop or transferred to your iOS device for importing (via the clipboard) into Strat Mobile. You can also save default lithology definitions by choosing File>Save Defaults which will write your preferred lithologies to the user preferences folder of your computer.

Formation Definitions

Formation definitions, like lithology definitions, can be exported as a simple text file by choosing File>Export Formation Types. This file can be read into another stratigraphic section in Strat Desktop. This will allow you to standardize colors and widths between formations.

Export for SedLog

SedLog is a popular share/freeware program for building stratigraphic sections that is available for any computer that can run Java apps. It is available from:

http://www.sedlog.com

Strat Desktop can take your Mobile/Desktop sections and save them as comma separated values for easy import into SedLog. Your thicknesses are changed to centimeters (required by SedLog) and, because SedLog does not have the concept of separate point observations (i.e., “Samples”), any sample ID numbers attached to intervals are written to the Notes field.
If you use SedLog extensively, you will probably want to set up as your default in both Strat Mobile and Strat Desktop a suite of lithology types that are compatible with SedLog.

**Menu Summary**

**File Menu**

- **New** — Opens a new, blank window
- **Open** — Opens a data file in the correct Strat Mobile/Desktop format for entering into the program
- **Import Lithology Types** — Read a file from disk that has lithologic names, colors, and widths already defined. This will delete any unused lithology types and lithologies that already have intervals assigned to them will assume the colors of the imported types with the same name.
- **Parse Column** — Read in a tab or comma separated column oriented text file from any program or spreadsheet to import into Strat Desktop. After opening the file, the Parse Text File dialog box will appear, allowing you to assign columns to Strat Desktop data types. Files with either tops or thicknesses, and measured either bottom-up or top-down can be parsed.
- **Save** — Saves a text file in the correct Strat Mobile/Desktop format wherever you specify on your disk.
- **Save SVG file** — Saves a vector graphics file in scaleable vector graphics (SVG) format which you can open in your favorite vector graphics program (e.g., Adobe Illustrator). The section and the legend are grouped separately but all are un-groupable and fully editable. If you do not have a vector graphics program that can read SVG, open the file in any modern web browser and then save the file as PDF.
- **Save Defaults** — Saves your preferred lithology types and other settings to in the user preferences folder where they will be read in the next time you start the program.
- **Export Lithology Types** — Saves a text file to disk containing the definitions for the currently defined lithology types. Thus you can set up a suite of preferred lithologies and save them so that you can reimport them later or transfer them to your iOD device for importing into Strat Mobile.
• Export for SedLog — Saves a .csv file that can be imported into the popular SedLog program. Because SedLog does not have separate samples, any samples in Strat Mobile are written to the notes field in the .csv file.

Edit Menu

• Cut/Copy/Paste/Delete — These standard operating system functions only work within individual text files. You can, however, select multiple rows in either of the list boxes in the Data Tab and choose copy and they will be copied to the system clipboard as tab separated columns.

• Copy Section — Copies to the system clipboard the complete stratigraphic section with samples as tab separated columns. You can paste these into a spreadsheet or into a section in another window within Strat Desktop.

• Copy Lithologies — Copies the current lithology type definitions to the system clipboard for importing into another section or transferring to iOS.

• Paste Section — If you have text on the clipboard formatted so that Strat Desktop can read it, you can paste the section into the current window. You will be asked if you want to append or replace any existing data. If you choose “append”, the section on the clipboard will be pasted at the top of any existing section.

• Paste Lithologies — Assumes the information on the system clipboard is a correctly formatted suite of lithology definitions for pasting into the current section.

• Find in Notes — You will specify some text and the program will look for that text in the notes field of both Intervals and Samples. The search is case-insensitive. You will be shown the details of the first interval or sample which contains the text.

• Find Again — Search for the same text specified in “Find in Notes” in subsequent records. The program will inform you when you come to the end of a search.

Section Menu

• Add Interval / Add Interval at Top — If you have a blank window, the first choice will read “Add Interval” and you can select this to start building a section manually. If data have already been entered, this menu choice will read “Add Interval at Top”. Select this to add a new interval manually at the top of an existing section.

• Add Interval to Base — Use this command to add a new interval at the bottom of an existing section, underneath all those already entered.
• Insert Interval Below Selected — This will insert a new interval in your section beneath the interval which is currently selected.

• Well Data submenu:
  • Add Well Data — Displays the dialog box discussed in the Well Data section
  • Extrapolate Velocities — If you have entered sonic velocities for some units but not others, this will go through your section and assign velocities to any formation that does not have a velocity assigned.

• Add Sample — In no samples are selected, this will add a new sample at the end of the sample list. If a sample is selected, it will insert the sample below the selected sample.

• Delete Selected Interval — This menu command will delete not only the selected interval but also any samples associated with that interval. All of the samples higher in the section will be moved down by an amount equal to the thickness of the deleted interval. You are asked if you are sure…

• Delete Selected Sample — Use this command to delete the selected sample. You are warned that the action cannot be undone and asked if you are sure…

Plot Menu

• Section — Turns on or off the plotting of the section (though I don’t know why you would want to do so!)

• Samples — Toggles the plotting of the samples to the left of the column.

• Legend — Toggles on or off the plotting of the legend (the boxes to the right of the section.

• Labels — Turns on or off the plotting of the formation name labels immediately to the right of the section.

Windows Menu

• Inspector Palette — Displays the Inspector Palette where you can set many of the graphical characteristics and units of the section.

Help Menu

• Strat Desktop Help — Displays this document.